Extruder Stepper Won't Turn

I have the 1.5XT with the dual extruders and recently extruder one stopped working. The motor powers on and then if I send it a command via Simplify3D or using the LCD control it will only rotate a few degrees back and forth. This is with no filament and pressure relieved from the idler bearing.

I have tried adjusting the potentiometer and even swapped out the driver with the extra one supplied with no change.

I then wondered if it was the motor itself burned out or something so I swapped connections at the extruder motors so that Motor 2 was connected in the Motor 1 location. Motor 2 then operated with the same issue and motor 1 was working correctly. I even had an extra RAMPs and Arduino Mega I swapped out and the problem still persists.

The only thing I can image at this point is something to do with my cable so I ordered some components to build my own to test this and for future expansion. Any other thoughts would be greatly appreciated.


New Member
Hi Casper,

When i built my own gMax (using the work gMax), i encountered a problem similar to yours i think...

When you say they only rotate a few degrees in each direction, is it a kind of stutter movement that changes directions randomly?

These NEMA Stepper motors contain two Pole Pairs, each Pole must be wired to it's correct partner, otherwise it could produce the behaviour i described.

Firstly check the connectors on the Wiring Loom and make sure none of the pins have retracted from the plastic connector, check for broken or damaged wires, and also make sure the connector is correctly plugged into the RAMPS.

Seeming as you have swapped the Driver and Tested another motor, a wiring issue is next on the list of troubleshooting imo.


EDIT: After re-reading your post, if you mean the motor operates properly but only for a few steps in either direction, then my checks may not be applicable to you.


Staff member
Maybe the stepper driver died. Contact us via email and we can get you a replacement.

The other possibility we've seen (in rare occasions) the connector to the stepper driver (where the wire plugs in) may be getting poor contact. As you try to use the 2nd extruder and it's acting weird, try moving the wire at the connector to see if it fixes the problem. We have a motor in the shop (used on a production printer) which has this problem. If we never move the printer its fine but if it gets moved it will move erratically. In this case we moved it to the x-axis and secured the wire.
I’m having this issue now, on our 1.5XT+. The main extruder stepper motor started clicking instead of turning, wouldn’t feed filament. I adjusted the driver, but that didn’t help, so I swapped in the motor from the secondary extruder head. That worked OK for a bit, but that motor is now failing to feed more and more often. So I’m assuming we have a bad driver.
Replaced the stepper drivers. Replaced the extruder stepper motor. When reconnecting the plug, noticed that the yellow wire was broken. :rolleyes: