gMax 1.5+ Marlin Firmware 1.1.1 Upgrade


Staff member
We have adapted the latest Marlin 1.1.1 firmware for the gMax 1.5+ printer. We are looking for feedback as we push this out to the community. We have been using one form of the new firmware in-house during our extensive testing period with great success. A huge thank you to the Marlin developers and the Marlin community. They made this happen and we are proud to support them.

The firmware can be found here:

Below is the change log which can be found in the zip file.

Marlin 1.1.x marks a major evolution in Marlin firmware. Over the past several years many enhancements have been made in the Marlin firmware project and below is a list of the major changes for the gMax printer. A huge thank you to the entire Marlin firmware development team for all their hard work and countless hours of tweaking. Also a huge thank you to the Marlin community for making this happen. Note that with this new firmware, you will see some changes from the youtube and printed tutorials.
To support the Marlin firmware project make sure to download, test, and comment on the code from the Marlin github:
And always check out:

Marlin 1.1.1 gMax 1.5+ Changes (Code is from 5-12-17 on the github)
• BLTouch:
BLTouch support officially added to firmware
Improved BLTouch performance (introduced 400ms delay and error checking)
BLTouch testing added to menu
Bltouch Deploy, stow in menu
Bed Leveling:
36 point leveling grid instead of 4 or 16 point
Bi-Linear bed leveling mesh accounts for high or low spots across bed
Leveling grid will interpolate beyond edge of probing
• Double tap LCD screen knob to access Babystep Z after a print has started
• Printer Stats (About Printer):
Printer info, thermistor info, firmware info
Print timer, filament length, longest job, total extruded length
• Stability and code quality improvements for LCD screen, printing, sd card error checking and across every portion of the firmware
• M600 filament change. Pauses print, moves to left side, extracts filament and waits. Note: If the printer has 45 seconds of inactivity the hotend cools down. When ready insert filament, extrude filament and resume print
• Splash screen showing gCreate logo separate from Marlin logo
• Cleaned up interface and removed unused icons. Less pixel changes for better response time
• New interaction with Prepare > Move Axis
• EEPROM saving:
Save bed level sensor offset (z-axis). Refer to manual for info
Save acceleration, jerk, speed and steps variables
“Restore Defaults” will restore the printer to the factory settings
• Filament runout sensor on pin #4 on RAMPS v1.4. Firmware can be tweaked to have high or low active state. Note: you need a physical sensor to use this function
• Bi-Linear bed leveling. With the new firmware, the interaction with bed leveling has slightly changed
Go to Prepare > Auto Home
Go to Prepare > Move Axis > Move Z > Move 0.1mm
Lower the nozzle until it just barely touches the bed the bed. Look at the Z-Axis height and write it down
Go to Motion > Z-Offset and add the number from before. ie (-1.9) + (-0.15) = -2.05
Go to Prepare > Save Settings
The next time you start a print, if you have to Babystep Z make sure to adjust the offset again for future prints.
• Fixed “Wait Command” so screen will not show “Sleep…” from S3D files
• …and many more changes in the firmware which we hope to utilize in the future
I have a dual extruder gMax 1.5+ XL that I took delivery from gCreate.

I've just installed the Marlin 1.1.1 firmware. The installation process went exactly as expected.

In bullet titled "Bi-Linear bed leveling" in marlin_1.1.1_changes_gcreate_170517.pdf describes a calibration process. The first step of this process completed without error. However, the final column of touch points resulted in the gantry moving so far over in the Y direction that the Y max limit switch was hit.

As I try to perform the second step of the calibration process, lowering the Z until the extruder(s) just barely touches the bed, the Move Axis operation won't move the Z either up or down. I can only guess that this is because the gantry is still positioned from the first calibration step such that the Y max limit switch is still high.

I'm not sure how important it is that the gantry not be moved in order for this second step to produce the correct Z height value.

Has anybody else experienced this condition and have a recommendation on how to proceed?


- Bob
Blows that theory...

I used the Move Axis functions to move the gantry and bed away from the far corner. But even after doing so, the Z axis can not be raised or lowered using the Move Axis function. However, the Z Move Axis function DOES work if I power-cycle the printer.

Once I power-cycled the unit, I then reran the Level Bed function. Once again, the Z Move Axis function would not raise or lower the Z axis following the Level Bed function, even after moving the heads away from the corner of the bed.

Anybody else seeing this behavior?

- Bob


Staff member
In the Quick Start Guide we mention to "Auto Home" the bed when adjusting the BLTouch offset instead of the "Level Bed" function. This was just a typo for the Marlin firmware change log.

We will update the text on the forum and on the PDF.
Hey all,

Since installing the new firmware my extruder (standard jhead) does not extrude. It seems to start extruding, but everytime it starts it retracts the same amount, resulting in nothing being extruded. Any of you encounter this issue?
Since installing the new firmware my extruder (standard jhead) is over extruding alot and the flow adjustment on the control head appears to have no affect. Where can one find the original firmware I'd like to revert back to what I had which was working great...


Staff member
dlabore said:
Since installing the new firmware my extruder (standard jhead) is over extruding alot and the flow adjustment on the control head appears to have no affect. Where can one find the original firmware I'd like to revert back to what I had which was working great...
The old firmware is in the same area of the forum depending on your setup.

We haven't changed the extruder steps in the configuration.h file from the old firmware so we would be interested to see why your flow is so high. Is it possible you modified this in the original firmware?

#define DEFAULT_AXIS_STEPS_PER_UNIT { 80, 80, 400, 96 } //Standard gMax settings
OK got it!

Turns out the problem of over extrusion after installing Marlin 1.1.1 firmware was a slicer issue. I tried printing one of the test files that came with the machine (keychain) and that printed fine. So I went back and re-sliced my fusion360 design (using simplify 3D) and now it prints perfectly? Don’t know why my Gcode files that printed fine with the old firmware wouldn’t extrude properly after I installed firmware 1.1.1 , but re-slicing them seems to have fixed the over extrusion issue. :)
After Installing the Marlin 1.1.1 Firmware with the "gMax 1.5+ Single Extruder E3D" Configuration.h file.

I use Auto Home, it puts the Z height at 13.9. I then adjust the height down by 0.1 till it just barely hits the bed. Z height is now at -1.09. (13.9) + (-1.09) = 12.81. Then I go to motion > Z-Offset I can not put in anything over 10.

in the file I noticed:
//gMax Single E3D Hotend
#define X_PROBE_OFFSET_FROM_EXTRUDER 11 // X offset: -left +right [of the nozzle]
#define Y_PROBE_OFFSET_FROM_EXTRUDER -23 // Y offset: -front +behind [the nozzle]
#define Z_PROBE_OFFSET_FROM_EXTRUDER -1.9 // Z offset: -below +above [the nozzle]


#define Z_CLEARANCE_DEPLOY_PROBE 12 // Z Clearance for Deploy/Stow
#define Z_CLEARANCE_BETWEEN_PROBES 12 // Z Clearance between probe points


// For M851 give a range for adjusting the Z probe offset

I just purchased the Powder Coated Metal LCD Screen + Full Graphic Display from the gCreate store and installed it yesterday.

I updated the firmware to the 1.1.1 this morning; but now I am getting a high pitched tone and the display is not working correctly. the X, Y and Z displays are flashing between the letters and a "?".

I have checked all of my connections and can't see anything wrong. has anyone had a similar issue?
Followed the youtube video to upgrade the firmware for my gMax 1.5+ dual extruder. Downloaded firmware 1.1.4 from the github page. Uploaded it through the arduino app as suggested. Turned on the printer and get nothing but a blank screen.

Just tried reinstalling the firmware from the gcreate downloads page. same thing. I'm using the Arduino/Genuino Mega or Mega 2560 board, with the ATmega2560 (Mega 2560) processor (in arduino)

Now what?