the fan is on and I'm not sure if the squirtle is supposed to look that way. I assume your talking about the slight jittery look it has, i wondered about that too.

I began printing the t nut and the shifting is definitely back i went back to the gear that i had success with it too has began having shifting issues and i haven't made any changes to the pots since the last one i printed. I'm completely baffled by this thought i had the problem fixed but clearly its not. Not sure what else to do.

looks like its shifting to the rear of the y axis


Yupp, that's the Y axis all right. I know which way the t-nut is oriented like the back of my hand...

Have you tried increasing that (Y) potentiometer or decreasing it?
Not sure what to do at this point in time... If you have a single extruder machine, replace the Y stepper driver board with that of E1. Not saying your Y driver is bad, but I'm out of ideas. Tell me if that changes anything...
I had a the same misery up until about 30 minutes ago. I read on a RepRap forum that you need to really keep the Arduino Stepper drivers cool or you get print shifting (as the drivers screw up so much internal logic when they overheat!), and someone suggests a house fan pointing at the Arduiono directly. I did this right in the middle of one of my miserable "shifting" prints, and after I opened the Arduino box and pointed the fan at it for about 1 minute, the print started to print correctly. I jumped for joy and ran around the house.

My 5 year old came to take a look and kicked the cord on the fan, and the behavior of "shifting" cam back! I plugged the fan back in and it magically finished the print. See attached picture and you can see the change and also the moment the fan got kicked out. I could attach about a dozen failed prints, but now that I have this solved, my mood is elevated and I am going out for dinner.

Also, I have read and talked to many about how much power to put into the steppers via the little analog pot. You want to drive at the highest voltage you can get, but also back off before their make that clicking sound. They should just whine a bit, and then you have it at the sweet spot. With my steppers, this feels like about 75% of the total rotation of the pots for me to get max power, before going to far.

Gordon's printer uses a nice stepper actually. I looked into it. It has 0.45Nm of torque and uses 1 amp, and that is pretty good ratio. So it seems these Arduino drivers can only handle 1 amp, so if anyone is thinking of a new stepper for the Z-axis (if they make a heavier bed), you will most likely need a better driver for the Z-axis channel.


That could very well be it! I haven't experienced the issue in the way you are describing but I do have an 80mm computer fan precariously perched horizontally on top of the electronics box (without the cover in place). If you want to do this immediately grab an 80mm Dynex fan at the local best buy, the reason for this is that it comes with an adapter that will allow you to tap the fan into a spare molex 4 pin connector on the printer's power supply.
i actually have two fans in the same room as the printer facing towards it so I moved one right up to the Arduino and nothing changed. I also started turning the pot to increase the power and now its really out of wack so im working on getting it back. I dont know whats up with this printer at this point :|
I have the dual extruder printer and there's a lot going on around the motors so i don't want to mess with that. But i will try swapping it with on of the motors from the z axis.
Also want to add that Ive been trying to get my potentiometer turned up like you all say you have yours but some reason i can only turn it about a quarter to the left or right before it stops working altogether so i had to keep it somewhere in the middle around. But as of about 5 minutes ago its has stopped moving completely... im going to keep turning it to see where it has to be now so it can work if it hasn't just died on me.
just swapped the motor and the problem is still there. This is getting to be very frustrating ,could someone maybe post a pic of there
potentiometer positions. Maybe mirroring your potentiometers will improve mine? Not sure what else to do.
Agreed, usually this problem would be resolved with this amount of fiddling.

Let's make it very simple. Don't print anything. Using the Manual Control Tab in Repetier-Host, tell the Y axis to move in one direction. Increase the pot a little and press the button again. Do this till you get movement.
I may have jumped to the wrong conclusion on overheating and a fan as the cure to the shifting problems. Let me explain my new discoveries, 12 hours after my initial success.

I live in Thailand, so it is always hot here. My room with the printer is about 30C (86F) and the aircon is barely blowing cool and I need to get it fixed. So you can imagine, electronics get hot.

Today I decided to see if my printer stayed “fixed” over night. My first print (air-con on and 82F ambient with house fan pointed at the Arduino) started off OK, but then exhibited minor (but tragic) layer shifting. Second print I turned the fan off and air-con off, (ambient air of 86) and it was a total disaster, so I felt my previous hypothesis of the overheating was correct. But, my third print made me question this theory. My third print was air-con off and fan off, with ambient temp at 87F; the print started off pretty horrible and then in the middle of the print I heard the X-axis motor making a little “chirp” from time to time so I turned down that pot a teeny tiny amount and the print immediately improved (you can see in the picture). Then I did another identical print, fan off, air-con off still, and it came out perfect. So I did another one in the blazing heat of my man-cave, and it came out perfect. I then did one more print (in full on heat mode) and it came out perfect. I went to lunch. See the attached picture of my 6 test prints this morning.

My theory on the heat is now blown. I have no idea of why I get shifting prints at various times. I celebrated too early last night, mostly due to the lure of a good meal and cheap beer.

Also: My belts are tight and not slipping. I have used Singer sewing machine oil on all moving parts like the solid rods and threaded screw for the Z-axis. I use the LCD and move the Z-Axis top to bottom and works great. I manually push the extruder along the X-Axis and it moves smoothly. I push the bed, and it moves freely.

Other issues around printing that may be part of the mystery: I run my code from the SD card, as I cannot get 4 different notebooks (and 2 cables I know that work) to talk to the Arduino. But interestingly, I must have the PC turned on with the USB cable plugged in in order to print from the SD card. If I do not plug in the PC/USB/Arduino, the control panel still works, such as “home” and moving axis and other functions. But if I try to print, without the PC as part of the equation, nothing happens after I select my file to print (using the LCD screen). It just sits there and the head temperature does not budge and will not do a print , but I can regain control with the LCD panel by cancelling print and doing all the other functions like home and moving axis’s. I cannot print without the PC attached. PC has no function other than being plugged into power and then plugged into the USB port on the Arduino.

To add to this mystery, I cannot communicate with my PC to the printer. I know the power goes from my PC to the Arduino, as I can see that happens as I unplug the mains power from the printer, and the Arduino controller continues to run and the LCD runs. But I cannot get the PC to talk at all to the Arduino, and I have used 4 different notebook computers (I feel like Edward Snowden), and have downloaded the latest Arduino IDE to make the magic happen. In my Windows “device manager” list, there is no magical appearance of the “Ports (LPT COM)” as part of the tree of devices, as per all the various Arduino instructions. I have read forums on Arduino and getting this to work for about 5 hours, with no improvement. Seems a lot of folks cannot get their notebooks to talk to Arduino, but others just say “follow the instructions, it is easy”. Any suggestions would be super appreciated.

Because I cannot talk to the Arduino, the firmware, etc.. is as it was shipped by gMax.

Lastly, I have another odd problem: my prints start at random positions on the table. If I am lucky, they are close to the middle. But very often, the extruder will go right to the edge and just start printing! Just thought I would mention it, if someone thought it might be related.

- My print shifting issues are no longer 100% certain blamed on heat. Not sure what the pattern is. Not sure if it really gone away.
- Odd problem, not sure if it is related, but my notebook(s) do not talk to the Arduino, at all. Any suggestions welcome, as I am about to pop for a new Arduino to see if that fixes it.
- To use the SD card, I must have the notebook plugged in and powered up. Power is getting to the Arduio via the notebook, as it stays on if I pull the mains plug.

I am getting rather burned out, as I have put a lot of time into the printer, and was hoping to be a bit further ahead! Can anyone help or make a suggestion?

To: JUSTDON; my potentiometers only turn about 270 degrees, and that is it. So, mine are now set at the middle of their possible travel, maybe a tad higher. I am to the point of replacing my Arduino and RAMPS (the Arduino first), to see if that allows me to get control of the system via the USB cable. You may need to also think about this rather drastic move (for you I would replace RAMPS first). I am extremely frustrated with all of this and if some money cures it at this point, I chalk it up to a life lesson. The boards and prices (gulp on the RAMPS) is here: ... kits/ramps


I have been to this page many times: but it never works.

I download successfully the 55MB package (1.0.5-R2), and I get all the options to install and install everything (“Arduino software, Install USB drivers, Create Start Menu shortcut, Create Desktop shortcut, Associate .ino files”).

I connect to the board, as per the instructions. I get no audible sound, like when I usually attach to a USB device, but I push on.

So, I cannot get past item #4 in the instructions “Install the drivers”. The document says “Plug in your board and wait for Windows to begin it's driver installation process. After a few moments, the process will fail, despite its best efforts”, but absolutely nothing happens. There is nothing list in my Device Manager for “Ports (COM & LPT)”. If one cannot get it to work at this point, all else will not work.

I have attached 2 pictures, taken on 2 different notebooks. The pictures show Device Manager with no “Ports (COM&LPT)”, and it also shows Arduino IDE 1.0.5-R2 running with Mega 2560 selected and the serial port grayed out (unselectable), and also shows the Windows environment and service packs on the machine.

In Gordon’s documentation and in the Arduino documentation, it always shows “Ports (COM & LPT)” between “Portable Devices” and “Processors”, but I have no such entry. I also get no new entries in my USB section (as seen in both attached pictures).

I have installed and tried on 4 different notebooks, one of them running Windows 8.1 Pro and three of them on Windows 7 SP1Ultimate. My notebooks have plenty of USB ports, but no serial or LPT ports.

I have 2 USB cables, and both work on other devices (printers I have). There appears to be power going from the PC to the Arduino via the USB, as I can get the pretty lights to turn on and the LCD to turn on (no white LED on the extruder turn on, as I guess its power comes from the main supply).

For me to print anything on the gMax, oddly enough, I need to use the SD card, but I also need to have the USB plugged in and doing nothing. If I unplug the USB, the menus on the LCD still work, I can make it “home”, but if I try to print it just sits there and never heats up (to repeat: that is running on mains power with no USB plugged in).

Any ideas on how to troubleshoot my communication with the Arduino?


It may be merely a coincidence but its interesting that both Uprightfan and I are having the same problem and we both print using the SD card...
I never got repetier working on my mac but I guess i should start fiddling with that.
Unfortunately I cannot try to replicate your issue until I return home this weekend, but I recall having a similar issue the first time I was working with an Arduino a couple of years ago. The drivers would not install with the board connected via USB. I think I just had to unplug the USB and rerun the installation. (But I may have uninstalled the software first before trying the reinstall) Once the install was complete, I plugged in the USB and the drivers were loaded and the ports were created. I didn't quite understand all the steps you took and if the USB was plugged in during the install. I also seem to recall the directions given didn't match how I had to do it. If you have already tried that, my regrets. I don't have any more bad experiences with Arduinos. They have worked well once the drivers have loaded correctly. I am running Windows 8.1 as well.
Today, I have used a Windows 7 SP1 and a Win 8.1 Pro notebook.
1) I uninstalled Arduino on both, then reinstalled. I then plugged in the Arduino. No change.
2) I uninstalled Arduino on both (a second time), then reinstalled, while the Arduino was plugged in. No change.

I get no sound out of either PC, like one does when you plug in a USB device. Am I supposed to get a beep of any sort?

I just pulled out the Arduio board and plugged it in (to both machines). No beep from either. No activity at all.

I have a pretty green power light (marked "on"). I also have an amber light that is on, near the USB connector, can't figure out the mark on the board, perhaps it is an "L". There are no jumpers on any pins.

The board is a proper "Made in Italy" board and is Rev 3.

I have not hit the reset button, as it was not in any instructions. Not sure of it shoots missiles to the moon, or something.

Any suggestions? Is the PC supposed to beep when you plug them in (like any other USB device)?
I took my installation back to zero to see if I could replicate any of the same issues on my Windows 8.1 laptop, but no (bad) luck...

Here's what I did:
1. I uninstalled Repetier Host using Uninstall from Programs and Features in the Control Panel
2. I plugged in my gMax printer and went to the Device Manager under "Ports (COM & LPT)"and uninstalled the drivers / deleted the COM3 Port (Arduino Mega 2560)
3. I uninstalled the Arduino using Uninstall from Program and Features in the Control Panel.
4. I plugged back in my printer to see if the computer would recognize it. It did not. I unplugged the printer from my computer.
5. I did a clean install of the Arduino 1.0.5 r2 - windows software with all the options checked
6. I did a clean install of Repetier Host 0.95
7. I plugged in my gMax vis USB.
8. The drivers were loaded without an issue and COM3 was created under "Ports (COM & LPT)" in the device manager
9. I started Repetier Host, went to Printer Settings under the Config Menu and selected the COM3 port for the default printer. (COM3 was created on my computer. I expect it could be numbered differently on others) I didn't change any other settings. I edited the Printer name to gMax and clicked on "Apply"
10. I then clicked on the "Connect" button in the upper left in the main Repetier Host window. The printer connected without issue.
11. I went to the Manual Control tab on the right) and clicked on the x and y arrows. The printer responded and the bed moved correctly.
12. I disconnected the printer, went back to Printer Settings under the Config Menu and changed the size of the printer bed to 410mm (x) by 400 mm(y) x 210 mm (z) and hit "Apply"
13. I reconnected the printer, loaded an .stl file, sliced it and printed.

I did not run into any difficulties. I did not have to do any additional steps to get Windows 8.1 to recognize the printer and create the COM3 port I just installed the programs without the printer connected via USB, then connected afterwards.

UprightFan - you may have an issue with your board, but I can't offer any other checks you may be able to run. Debugging electronics is not a strength I have.

Also - I do not need to have the printer connected via USB to print from the SD card. I plug in the printer's power cable and insert the SD card and print straight away. Is your power in Thailand clean & stable? I lived overseas for a number of years and had to run through voltage regulators to minimize the spikes/disconnect during drops to save the gear. Sometimes that didn't work despite best efforts. Surge Protectors alone didn't cut it.
I spent some time talking to Don Bedwell (the other Don not in this thread) and he's been having some similar issues. I walked him through re-uploading the firmware to Arduino and he was able to do so successfully but can't get Repetier-Host to talk to the printer. Something is up... And I don't want to say that the electronics are bad but the moment he turned on the power supply we lost the tiny bit of progress we had made...