Looking for help - MINTEMP, MAXTEMP errors, LCD corruption

Hey everyone,

Doug Clark here, owner of a new gMax 1.5 XT. I just recently completed the build (with some helpful assistance from Gordon and Anna - thanks!) and am now trying to complete my first print.

I've tried four times - all unsuccessful - to print a 20 mm square cube (http://www.thingiverse.com/thing:271736). The first three times I got a MINTEMP error, with only one of those attempts (the first one) actually getting so far as to start the print, though it did stop after only 28 seconds.

My fourth try was this afternoon, and I actually had some success. The cube started off great, and actually printed for 14 minutes before erroring out with a MAXTEMP error. (See attached image.)

Another issue - after almost every print, and within about 20 minutes of turning on the machine, the LCD becomes corrupted and I can no longer use it. (see several images attached.)

I have read all of the documentation I can find on the site, watched the four tutorial videos on the gCreate YouTube site, and read everything I can about the MINTEMP and MAXTEMP errors on the forums (which admittedly isn't much.) Not sure exactly what I can do to address this.

Here's what I've been doing:

0) Updated the firmware with the latest version from the gCreate website ("gMax 1.5 XT - Dual Extruder_Marlin-Marlin_v1.1_141223").

I've only done this once.

1) sliced the model with slic3r.

I'm using the slic3r settings from gCreate (gCreate_Slic3r_1-1-7_config_bundle_141014.ini), with the following items selected:

Print Settings: 05mm Medium Quality, making only one change - setting "Support material extruder" to "1" (it defaults to "2" for some reason.)
Filament: Colorfabb - PLA (generic) - selected twice (though I don't have any filament in the second extruder.)
Printer: Dual - 0.5mm and 0.5mm

I then click "Export G-code..." on the Plater tab and save the file.

2) Put the g-code on an SD card

I copy the g-code file created in step 1 onto the SD card supplied with my printer, and then insert it into the SD card slot of my printer.

(I haven't yet configured any control software (I'm planning on giving Printrun a go, but haven't gotten that far yet), nut I will if anyone thinks that should work any better...)

3) pre-heat PLA option

After not getting any plastic extruded the first few times I tried using the printer, I found the post by justdon where he suggested using the "Prepare > Preheat PLA" option, and using this I was able to get plastic to extrude. I now use this every time I print.

4) Select my model to print from SD card

Using the LCD menu, I select "Print from SD > [select my g-code file]". The printer then starts warming up...


print attempts: 4
MINTEMP errors: 3
Longest print before MINTEMP error: 28 seconds
MAXTEMP errors: 1
Longest print before MAXTEMP error: 14 minutes
LCD corruption %: 75%

Anyone have any idea what might be going wrong?


Re: Looking for help - MINTEMP, MAXTEMP errors, LCD corrupti

Hi Doug,


I also have a Dual Extruder XT and I experienced last week quite a bit of what you're experiencing now. Several of my issues went away immediately when I moved away from the standalone LCD screen and starting using Repetier-Host (free) via a laptop. I really wasn't planning on keeping a dedicated laptop with the printer but given how much more control I have over the printer and not having to sneaker net an SD card between the file source and the printer I can't think of why I would go back to standalone mode. You mentioned Printrun - I don't have experience with that host software but it's probably better than the SD card option. I wasted a lot of time in standalone mode simply because I was trying to figure out how to control the second extruder.

You can't control the second extruder via the LCD screen in standalone mode but you CAN control the second extruder from the LCD screen when the printer is connected to Repetier.

I've never received a max temp error but I have received min temp errors - never during a print though. only while idle. A power cycle of the printer fixed that. Make sure you remove the USB cable from the laptop to ensure you reset the Arduino/LCD too. Otherwise the Arduino and LCD will retain power and you will only be power cycling the steppers/LEDs and I don't think you'll clear the error (I can't reproduce your issue so I would assume cycling the electronics would at least cause it to re-read the sensor and retrigger the error or clear it).

You may also want to check and see if all the cables leading to the electronics are firmly seated. A few wires came preinstalled with my printer but worked their way loose during shipping. I am wondering if a connector is slightly loose and the vibration might cause the temp sensor to trigger the error. Especially since it happens on both the high and low ranges. - just a thought.

Regarding the garbled screen - this happens to me and I would assume everyone at some point. The LCD is really sensitive to static electricity and EMI. It occurred with greater frequency when I was printing in standalone mode. I don't know if the laptop/usb connection has a grounding effect or not - It still happens but not as much. It's really annoying though during a long print when you lose the ETA/ elapsed time. - the software can you show you this when the screen gets garbled. Try not to touch the printer once the print begins. I've been able to reproduce this issue by touching the printer/LCD. Its not 100% repeatable but I've been able to cause it to happen vs it just happen randomly. By chance are you in a carpeted room? This is a common issue I see when working with arduinos and inductive loads (there's alot going on it that box plus all the steppers). Capacitors/snubbers might be the fix but my priorities are getting the printer dialed in for production.

You may also notice that the LEDs flicker. At first I thought this was due to interference but I notice the LEDs flicker in conjuction with the LED on the ramps board. It seems like they're tied to the same circuit that PIN 13 is (Arduino's LED). This is just an observation and Kyle may be able to shed some additional light on this but I think these two issues were grouped together in another thread from last summer. But it seems like they're two different causes. The LCD issue is a result of static/EMI and the LED flicker seems to be a decrease in current. (based on the behavior I observed)

All of the steps you took leading up to getting the file on the SD card seem fine.

Hope this helps.

Re: Looking for help - MINTEMP, MAXTEMP errors, LCD corrupti

Thanks for the detailed response Larry!

I will give repetier a shot, and let everyone know how it goes.



New Member
Re: Looking for help - MINTEMP, MAXTEMP errors, LCD corrupti

I connected my printer up through Octoprint. It runs a web server so you can see the status of things from any device on the same network. If you port forward, you can get access from anywhere.

I run Octoprint from a raspberry pi and leave the pi connected to the printer all the time. I also connected the soft power-on wire from the power supply to the arduino and added custom controls in Octoprint to allow me to shut down and power up the printer through the web interface.

Octoprint will show progress, estimated time left, total print time, current temperatures, and gcode visualization. The print time estimates run a bit low, but it gives me an idea. I also have the raspberry pi cam and it shows up on the control tab in Octoprint with a live stream of the print.

I built my gMax from scratch rather than from a kit and have not yet gotten an LCD or power button. With the power wire connection, the pi, and Octoprint I don't feel the need for either the LCD, the power button or to have another computer constantly connected to the printer.
Re: Looking for help - MINTEMP, MAXTEMP errors, LCD corrupti

Check the connection to your thermistor. MIN_TEMP and MAX_TEMP errors are usually caused by the thermistor (temp sensor) not getting a good reading.

Restart the printer to reset the LCD screen. Or you can try re-inserting the SD card.