Marlin 1.1.8 update issue extruder moves up to top rail and crashes and grinds during bed level script

Hi Gordon,

I have a gMax XT+ single extruder E3D head, BLTouch, acrylic bed.

I updated to Marlin 1.1.8 using the Cura Hex file installation method.

Installation went without a hitch. But when I run the Level Bed script all the machine does is raise the extruder all the way up to the top bar until it crashes and starts grinding the stepper motors.

I tried auto home script and this time it goes up to the top grinds for a few seconds goes down to the bed and homes properly. Once done it will start to head back up again until it hits the top bar and grinds again.

I tried loading a test print I updated my Simplify 3d profile with the recommended gcode changes according to your documentation. But it runs the same bed leveling script again crashing the machine at the top.

Also the stepper sound much louder than the earlier firmware. I mean easily 5x loader they are screaming this started immediately even before the extruder hit the top bar.

Please help I have customer orders and this firmware update has killed my machine for now.
My machine has the old Blue Board. could that be the problem? If it is can you send me the link to Marlin 1.1.1 that I need to revert back so I can get this machine working again. I can't afford any downtime.

If Marlin 1.1.8 does not work with the old blue boards please add red board needed as a requirement so people don't break their machines.


Staff member
I would try loading the firmware again. Shoot an email to and I can send you a slightly modified version of the firmware. We have had marlin 1.1.8 installed on printers with blue electronics, so that shouldnt be an issue. Otherwise, here is the link to marlin 1.1.1
Hi Josh,

Thank you for the quick reply.

I installed the firmware again three times now and I get the same issue. I am using Cura 3.3.0 on OSX. The results are the same every time.
I sent you an email, once I get the modified firmware I will give that a shot and see if it works.


New Member
Hi I'm having the same problem with our gMax XT+ single extruder E3D head, BLTouch, acrylic bed.

I used Cura 3.1 to install Marlin 1.1.8.

Can you help, please.

I am having the exact same problem. The nozzle just keeps raising when starting a print until it hits the top and starts grinding. Please Help! I am running the new marlin firmware 1.1.8 on my Gmax Xt plus with ED3 hotend.


Staff member
We are trying to figure out why some printers are having issues with the latest firmware. The only solution we have found so far is to replace the electronics. We will continue to figure out a better fix for this situation. But if you are getting issues with the latest firmware, I suggest going back to 1.1.1 until we can find a solution.