Multiple issues getting off the ground


New Member
Screen seemed to work fine yesterday after assembly then we moved the printer across the office gently to it's permanent home and now the screen is only dimly lit with no text visible on the screen. We have checked to make sure the correct cables are plugged into their corresponding ports and the connections seem to be fully connected.
Any suggestions on this?

Also we are having trouble getting our PC to recognize the printer at all.
Do we need to install a driver first? We get nothing at all when we plug it into USB, not even the little chime windows usually gives you as an acknowledgement of plugging or unplugging a USB device.
The screen can act up in the presence of static. You can restart the printer or you will have to insert and re insert the SD card a few times. The problem is most likely static electricity. Grounding your self to a radiator or sink pipe will help.

You will need the arduino drivers installed in order for your printer to be recognized by your computer. You can download them along with the Arduino IDE from


New Member
Arduino installed
Windows does not acknowledge anything is plugged in.
Device manager does not show anything plugged in.
Port info only shows "Intel Active management technology - SOL (COM4) This shows whether the printer is plugged in or not.
No other "unknown devices" show.
Nothing shows under usb controllers or drives
I cannot get the system to work plugged in.

re inserted SD car multiple times - nothing.
System is plugged into grounded outlet so boards are grounded.
On the gadgets3d top board that the ribbons are plugged into for the display there is a small blue LED labeled d1 that is flickering constantly.
I tried e-mailing support, the Y-axis limit switch board has no LED where there is supposed to be an LED.
The first time I turned the system on the display worked. I turned it off, came in the next day and it did not??
I need to get this working for a couple projects. I am in Massachusetts. Can anyone help?


New Member
The limit switch LEDs turn on when the switch is triggered. Are you saying the LED does not turn on when the switch is pressed?


New Member
If you unplug that endstop, does the computer see the printer?

Also, if you shut off the printer's power supply, does the computer see the printer?


New Member
When you say you unplugged it, you are talking about the endstop? If that's the case, it sounds like you just need to replace that endstop. Gordon can probably get one to you. If you need it fast, you can always order one yourself.

They can be found on Amazon or eBay pretty cheap. I used Amazon before because I could do prime shipping, however I got one endstop that had the switch soldered on backwards which caused issues. Others had the same issue so I posted in the Q&A section on the item how to determine whether the switch is backwards. I was able to desolder the switch, reverse the bend in the prongs, and resolder it without issue. However all you need is one, so if one is wrong it won't matter for you.


New Member
It would be nice if Gordon contacted me or if they would respond. I have been trying to e-mail people since last Wednesday. I can not find a phone number either.

I just unplugged the limit switch and the computer recognized the device and the LCD turned on. I will try on amazon. Thank you so much for the help.


New Member
No problem -- I love the cars, btw. I've seen a couple of AC Cobra replicas at local autocrosses. I didn't talk to the owners, but I would guess they were made from kits produced by you guys.


New Member
I found a couple problems with the Y-stop.

I replaced the Y-stop with a new one. I then found the LCD screen would only go on when I pressed the stop. I found the wires in the plug for the y-stop inside the electronics enclosure were in a different order than the wires in the other axis stop plugs so I took the pins out of the plug and put them in the correct order.

Now the LCD screen works and the printer was recognized by my computer.
ahh man, I hope I don't run into any problems like this, I can be tech savy sometimes, but usually it's when I know what I'm looking for. Was the wires in the wrong placement something you did on your end when building or is that how it was sent to you?



New Member
The wires were wrong in the plug but it was obvious when I looked at the three limit switch plugs on the board. It was different than the others.
Hi Jman. I'm having exactly the same problems you're having, mainly with the printer no longer able to read from the SD card. Can you help me out? Can you tell me what the "endstop" is and maybe that would solve my problem? Also, I tried to set up an external computer to run the printer and I have Arduino installed on the computer but the computer does not show a com port from the printer. I have more info on a separate post I put up yesterday:


I haven't heard back yet from Kyle from gCreate. They originally sent me replacement ribbon cables thinking that might solve my SD card reading problem but it didn't help. It was weird when it stopped reading the SD card. I was running a print and aborted the print to remove the SD card to make changes in the gCode (I did not turn off the printer). I reinserted the card and the printer no longer was able to read it. That was three weeks ago.

Any help would be greatly appreciated.



New Member
The endstop is the switch that the table hits if you move it all the way towards you if you are in front of it. There is another one on the left vertical post that gets hit when the bar that the print head is on goes all the way down. The last one is the one that the print head hits when it goes all the way left.

I assume that you tried turning it off, put the card in then turned it on again?

If you plug the printer in it will not show up without another program. When you run the printer from the computer you have to use another program like Pronterface:

or simplyfy3D:

I use pronterface but I have found that the file size it can take is limited so using the full height and area of the 1.5x is not possible. I would try simplyfy3d which gcreate supports if you have the option.
Hey thanks for the info about the endstops.

Yesterday I was able to get Arduino set up on my laptop for running the printer externally from the computer. I would definitely recommend using Simplify3D as it has worked extremely well for me and now I will use it to run the printer from the laptop until I can get the printer to be able to read the SD card again. Cheers!