SD Card wont load in printer

I started printing a part and decided I wanted to tweak the G-code. I stoped the print removed the SD card and went to reslice the part. When I came back and inserted the SD card the main LCD screen said SD card inserted, but when I tried to retrieve my gcode files it said there was no SD card. I'm not sure what to do since it was working ten minutes ago and doesn't anymore. I can't think of anything that would have changed, causing this problem.
1. Removing and re inserting the SD card.
2. Power cycling the printer.
If this does not work...
3. Reload the g-code. If you do not remove the SD card properly from the computer the file can be corrupted.

Hope this helps,
I have this problem too and sometimes have to reinsert the SD card or cycle the printer a time or two before I can get the printer to recognize the card. This may be related to static electricity that builds up in the card as I am carrying it from my PC (inside the house) to the gMax (in the garage). At first I tried wearing rubber gloves to move the SD card but that proved to unwieldy. So I connected a ground wire at the PC and one at the printer which I touch to discharge the static before I insert the card in either location. This also helps prevent the "LCD screen displays a bunch of crazy characters" issue located elsewhere in this forum.