Terrible shift issues

Just rec'd our gMax 1.5 XT+ yesterday. Heated bed, Dual E3D Extruder. Ran through all the assembly, setup, test print etc. successfully. Everything looked good, so I kicked off a large print (14x14x12") and went home. I used Cura 2.7.0 and the "gmax_cura_normalquality_170530 - 0.2mm" profile to slice.

This morning we found that the printer had shifted a couple of times, in both X and Y directions, within the first several layers, and was now throwing filament off the edge of the plate.

I thought perhaps the cable from the heated bed might have caught on the end of the bed rail as the bed moved forward, which could account for the Y-axis shift. So, I made a custom rail end cap with an integrated ramp for the cable, to eliminate that danger.

That doesn't explain the X-axis shift, though. I haven't started another print yet...hoping to get some feedback here. Any ideas on what else might have gone wrong with the print? What else do I need to check?

I scaled the large print down to 50% and tried again. It seems to be printing properly, but it looks like the print is off-center in the X axis.

Am I correct that this is a problem? If so, how do I fix it? Do I re-run the "gMax Initial Setup.gcode" file from the SD card?

I always want to support enthusiasts and hobbyists and help to answer questions about lasers, engraving machines, so if you have any questions about lasers or you want to share with your experience while working with our or someone's else lasers, you are welcome to do this:
Share your story here!

If you have any issues you need to solve, do not hesitate to ask here! we will be happy to help!
Turned out to be a problem with the heated plate shifting in the mounting clips. I printed additional clips and anchored the plate at all 8 available points, and that seems to have solved the shifting print mystery.