Looking for 1.0 manual, firmware, config, etc.

Check here for instructions and tips on how to operate your printer.

Looking for 1.0 manual, firmware, config, etc.

Postby KSL » Mon Jul 11, 2016 12:23 am

So I got really busy for a long time, now trying to get my gMax 1.0 going again. Had a hard drive crash tween then and now, updated to Win 7.

Followed the arduino video, uploaded the 1.5 firmware (reversed the Y-axis I THINK), arduino talked to the board, the blue light flashed really fast for a while, the manual control panel works for moving the platform and print head. Now just trying to get any piece of 3d printing software to talk to the printer. Com port 4 in my case.

Any recommendations on current software? Working on reinstalling and config'ing Slic3r, but don't have 1.0 config file and or bundle. Bought Simplify3D, won't connect.

Anyway, still working on it, any pointers, tips or recommendations appreciated.

Thx,

Kent
These users thanked the author KSL for the post (total 0):
KSL
 
Posts: 12
Joined: Sun Feb 23, 2014 5:00 pm
Has thanked: 2 times
Been thanked: 0 time

Re: Looking for 1.0 manual, firmware, config, etc.

Postby sandman » Mon Jul 11, 2016 1:02 am

Not the biggest expert on 3D printing but if you want a great, free open source software, give MatterControl a try. I have been using it for several months with great satisfaction. Very easy to set up and use and I get consistent results. MatterControl has the printer profile for the gMax now so it's even easier to set up and get going.

http://www.mattercontrol.com/#jumpMatte ... lDownloads
These users thanked the author sandman for the post (total 0):
sandman
 
Posts: 19
Joined: Wed Jun 08, 2016 7:32 am
Has thanked: 12 times
Been thanked: 3 times

Re: Looking for 1.0 manual, firmware, config, etc.

Postby KSL » Mon Jul 11, 2016 1:05 am

Well halleluhah or whatever.

Pronterface talks to the printer. Makes it move and everything. w00t!

Still taking any tips or recommendations, especially any specific to 1.0

thx
These users thanked the author KSL for the post (total 0):
KSL
 
Posts: 12
Joined: Sun Feb 23, 2014 5:00 pm
Has thanked: 2 times
Been thanked: 0 time

Re: Looking for 1.0 manual, firmware, config, etc.

Postby KSL » Mon Jul 11, 2016 1:27 am

Hmm. Tried to reverse y axis in the configuration.h, but whatever I did didn't work, the bed homed in the wrong direction, which I kind of expected and pulled the plug before it hit anything.

So I undid what I did to configuration.h, reuploaded the firmware, and reversed the plug from the y motor on the arduino board. That also didn't work, which again I halfway expected and pulled the plug.

But now I have no idea what to do. :-/
These users thanked the author KSL for the post (total 0):
KSL
 
Posts: 12
Joined: Sun Feb 23, 2014 5:00 pm
Has thanked: 2 times
Been thanked: 0 time

Re: Looking for 1.0 manual, firmware, config, etc.

Postby KSL » Mon Jul 11, 2016 2:45 am

I got the X, Y and Z all moving in the right direction. Yay!

But the Y home command doesn't do anything. Home all axes does X and Z, but also doesn't home Y.

I found a loose white wire at the printer cable end of the board, reattached it, but that goes to the printhead, and in any event didn't enable, disable or affect Y homing.

Y homing was working, albeit in the wrong direction, even after the manual y jog started working right. Without any reversed wires or flipped axes in the configuration.h either. So I reversed the Y homing direction in configuration.h and it hasn't done a damn thing since. I changed it back to -1 figuring it would at least home the wrong way, but no such luck.

I'm tired, stumped, and a bit dejected.
These users thanked the author KSL for the post (total 0):
KSL
 
Posts: 12
Joined: Sun Feb 23, 2014 5:00 pm
Has thanked: 2 times
Been thanked: 0 time

Re: Looking for 1.0 manual, firmware, config, etc.

Postby KSL » Mon Jul 11, 2016 2:52 am

One last minor success, got simplify to talk to the printer. Baud rate needed to be set to 250000.

But no Y-homing there either. :-/
These users thanked the author KSL for the post (total 0):
KSL
 
Posts: 12
Joined: Sun Feb 23, 2014 5:00 pm
Has thanked: 2 times
Been thanked: 0 time

Re: Looking for 1.0 manual, firmware, config, etc.

Postby gCreate_Kyle » Mon Jul 11, 2016 2:50 pm

Check the end stop locations.
These users thanked the author gCreate_Kyle for the post (total 0):
Attachments
EndstopLocations.PNG
R. Kyle Gress
gMax Technical Support
3D Printing/Electronics Enthusiast
User avatar
gCreate_Kyle
 
Posts: 169
Joined: Mon Feb 02, 2015 8:47 am
Location: Lancaster, Pennsylvania
Has thanked: 11 times
Been thanked: 18 times

Re: Looking for 1.0 manual, firmware, config, etc.

Postby KSL » Mon Jul 11, 2016 4:32 pm

Everything seems to be seated correctly, and all the endstops operate. If I jog the bed into the y endstop, the switch works, the light comes on and the bed stops.

I've tried home y in pronterface and simplify, and sending the gcode command manually. For some reason the board isn't receiving it, isn't understanding it, or can't execute it. Since all the jog controls work, I don't think it's not receiving it, and since it does execute home all on x and z, it doesn't seem likely that it can't execute it, although I guess that's possible. But it seems more likely that it's not understanding it, i.e. the firmware isn't quite right.

Hence my search for the firmware for the 1.0 software circa September 2014. Cuz that worked. This model is from the first kickstarter, kit form, that I assembled, that worked. It got a little banged up being transported around, but I've repaired the structural stuff, just a few cracked plastic parts, and even beefed it up with some metal brackets. Everything seems to be correct, although I haven't got as far as testing the extruder/hot end yet.

Really hoping this is a software or firmware issue. If it's not, that only leaves something wrong with the board itself as far as I can think.

If anybody out there is operating a relatively stock gMax 1.0 and can send me or post their arduino sketch, that would be fantastic.

cheers,

Kent
These users thanked the author KSL for the post (total 0):
KSL
 
Posts: 12
Joined: Sun Feb 23, 2014 5:00 pm
Has thanked: 2 times
Been thanked: 0 time

Re: Looking for 1.0 manual, firmware, config, etc.

Postby KSL » Mon Jul 11, 2016 11:44 pm

So, the 1.0 manual, wiring diagram, firmware and config files are just gone? Somebody must have a copy, right?

XYZ axes all function correctly, X and Z home correctly, Y doesn't home at all, and I have a mintemp error.

Things are not going well. Is the 1.0 a dead platform now?
These users thanked the author KSL for the post (total 0):
KSL
 
Posts: 12
Joined: Sun Feb 23, 2014 5:00 pm
Has thanked: 2 times
Been thanked: 0 time

Re: Looking for 1.0 manual, firmware, config, etc.

Postby KSL » Tue Jul 12, 2016 10:21 pm

Today:

Manual control from the LCD still works.

Computer control no joy.

Connecting...
start
Printer is now online.
echo: External Reset
gMax Marlin 1.0.0
echo: Last Updated: Jul 12 201612/23/201419:53:33 | Author: Gordon LaPlante (Gordon LaPlante, gMax 1.5 Configuration)
Compiled: Jul 12 2016
echo: Free Memory: 4311 PlannerBufferBytes: 1232
echo:Hardcoded Default Settings Loaded
Error:0
[ERROR] Error:0

: Extruder switched off. MINTEMP triggered !
Error:Printer stopped due to errors. Fix the error and use M999 to restart. (Temperature is reset. Set it after restarting)
[ERROR] Error:Printer stopped due to errors. Fix the error and use M999 to restart. (Temperature is reset. Set it after restarting)

echo:SD init fail
These users thanked the author KSL for the post (total 0):
KSL
 
Posts: 12
Joined: Sun Feb 23, 2014 5:00 pm
Has thanked: 2 times
Been thanked: 0 time

Next

Return to gMax Operation Instructions

Who is online

Users browsing this forum: No registered users and 1 guest