E1 Heating Failed Printer Halted

#1
I have been dealing with this issue for a month now and still not able to resolve it. I have replaced the heater cartridge, thermistor which reads the ambient temperature correctly. I have been working with Joshua on this and we thought it was fixed but the error has returned. I have a dual extruder 1.5+ but currently running with a single extruder. We have switched the wires in the electronic box and still have the problem. We have taken the the hotend and connected it directly to the electronics board and it heats up - but this is a short test not one that involves any duration. I also have the gTouch on my printer and with that comes an Astroprint Keychain test print which I was able to print today. However when I tried to print the g spiral test print I get the E1 Heating Failed Printer Halted message. I was wondering if anyone else has encountered this problem and has any suggestiongs?
Thanks
 
#2
This is an update:
I initially reported that the printer printed the astroprint keychain test print then when I tried to print the spiral G it gave me the E1 Heating Failed Message. There was no movement on the lower reading and it was reading ambient temperature. I then turned the printer off and returned about an hour later turned it all on and was able to successfully print the G Twist test print. Possibly seeing a pattern I turned it all off again and waited for about 50 minutes and tried to print another object that met with the same E1 Heating Failed message. Ambient temp was correct and no change (i.e. increase) of the temp was seen prior to the error message. Just in case I wanted to see if the issue was in in the GTouch I disconnected it restarted the just the printer controller (without the gTouch) and tried a filament purge. This also failed with it reading the correct ambient temperature and seeing no increase in temp prior to the E1 Heating Failed message.
Given that I was able to print a couple of test prints and am seeing ambient temperature I am inclined to believe the error has something to do with the electronics board. Reasoning is that the message to heat is seen on the display but is failing somewhere in the electronic controller that allows the hotend to heat and keeps it in a desired heat range. This Is just a guess but it fits the symptoms.