What's new

Latest resources

Cura 3.5 - Installing updated gMax Configuration FIles gCreate
  • Featured
Install updated gMax configuration files for Cura 3.5.1
0.00 star(s) 0 ratings
Downloads
47
Updated
gCreate
0.00 star(s) 0 ratings
Downloads
67
Updated
gCreate
0.00 star(s) 0 ratings
Downloads
495
Updated
gMax 1.5+ Marlin 1.1.8 - Full Graphic Display Only gCreate
  • Featured
Marlin 1.1.8 firmware for the gMax 1.5+
0.00 star(s) 0 ratings
Downloads
951
Updated
Cura 3.1 gMax 1.5+ Single and Dual Extruder Configuration Files gCreate
  • Featured
Cura 3.1 config files for the gMax
0.00 star(s) 0 ratings
Downloads
585
Updated
gMax 1.5+ Fan Shrouds (4 Styles) gCreate
All the fan shrouds for the for the gMax 1.5+
0.00 star(s) 0 ratings
Downloads
76
Updated
gMax 1.5+ BLTouch brackets (4 styles) gCreate
0.00 star(s) 0 ratings
Downloads
53
Updated
gMax 1.5+ Volcano Fan Shroud and BLTouch Bracket gCreate
A new longer fan shroud and bltouch bracket for E3D Volcano
0.00 star(s) 0 ratings
Downloads
32
Updated
gMax 1.0 All 3D Files gCreate
File includes all 3d parts including single and dual extruder.
0.00 star(s) 0 ratings
Downloads
22
Updated
gMax 1.5 All 3D Files gCreate
File includes all 3d parts including single and dual extruder.
0.00 star(s) 0 ratings
Downloads
43
Updated

Latest profile posts

Hello Joshua,
I am looking to replace my E3D nozzle with a larger one for quicker printing times, but I see conflicting information on the website. What is the largest I can go with my 1.5xt+ printer? Thank you
Is there any way to purchase the steel electronics case with the boards and latest updates already installed?
Fairly new to 3D printing, and am currently using Cura. I am trying to align two models for a dual extrusion. YouTube videos all show it easily being done using cura and the Ultimaker. After following the steps in the videos, and assigning each model to a printer head and hit merge, it aligns the two models side by side instead of on top of each other. Has anyone figured this out?
Is Cura3.4 compatible with the gMax 1.5+ or does it have connective issues like the 3.3 version?
gCreate_Joshua
gCreate_Joshua
If you are using it just as a slicer, you can use any version of cura you want. But if you are uploading the firmware, you will need to use cura 3.1
gCreate_Joshua
gCreate_Joshua
It is compatible for slicing. Just not for uploading the firmware. We have also put out profiles for cura 3.5