Printer not reading SD card

My gMax 1.5 XT+ is no longer reading the SD card. I insert the card and the 1st screen says card inserted. But when I go to the screen showing the SD card, it doesn't show there is a card inserted and I cannot access any of the files on the card. I tried a different card thinking the first one was faulty but the same thing happened with the second card. So I am unable to do any printing at this point.

Please help if you can.
if you put the sd card in before powering up the unit does it work?
i had the same problem.
Mine ended up being the LCD screen itself.

Working with Kyle from gcreate we troubleshot the cables from LCD to Ramps board, etc. It ended up being the LCD screen.
Hi dunginhawk. Yeah, I tried it both ways - leaving the card in and turning on the machine or turning on the machine then inserting the card. Didn't work either way. When I insert the card the main screen does say "Card inserted" but when I go to the next screen it says "No card". I did send a note to Kyle about this over the weekend and haven't heard back yet but I know he will respond as he's good for it. How did you get yours solved? Did you have to remove the screen and send it back to gCreate to repair it?
Turns out, in my case, the fix was easier than expected. Something told me to blow into the card slot and, voila, it now is able to read the card again.

May not work for everyone but it is something to keep in mind.
Well, guess what, the machine is back to NOT reading the SD card. I had started a print but aborted it as I saw I needed to tweek the gCode so I removed the card. Then when I reinserted the card the machine said there was no SD card. I turned off the machine then turned it back on with the card already inserted. Nope. Turned it off, waited a couple of hours and tried again. Nope, again. Extremely frustrating. Anyone have any ideas?


New Member
It kind of sounds like you might have a bad connection somewhere. One thing to try is plug the SD-Memory card in and out 50 or 100 times. If either the SD-Memory card or the socket has some corrosion on the contacts, this might clean it off.
Hey Roxy. I tried what you suggested about inserting and removing the card many times but it didn't work for me. I doubt there's any corrosion as this printer is only two months old. I sent a note to Kyle last Friday at gCreate but no response yet. In the meantime I'm SOL. Thanks again for your suggestion.